Posted comments (4)

Posted by Praveen Kumar Patidar at March 5, 2010 12:43:16 CET
I am facing problem in installing. The progress bar showing
"Importing modules ... please wait". and in server log showing exception.

onal impact.
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoa
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoa
at java.lang.ClassLoader.loadClassInternal(
at org.apache.log4j.LogManager.getLoggerRepository(
at org.apache.log4j.LogManager.getLogger(
at org.apache.log4j.Logger.getLogger(
at org.apache.commons.logging.impl.Log4JLogger.getLogger(Log4JLogger.jav
at org.apache.commons.logging.impl.Log4JLogger.isInfoEnabled(Log4JLogger
at org.opencms.i18n.CmsLocaleManager.setDefaultLocale(CmsLocaleManager.j
at org.opencms.i18n.CmsLocaleManager.<init>(
at org.opencms.main.OpenCmsCore.initMembers(
at org.opencms.main.OpenCmsCore.<init>(
at org.opencms.main.OpenCmsCore.getInstance(
at org.opencms.main.OpenCms.getMemoryMonitor(
at org.opencms.publish.CmsPublishQueue.isEmpty(

at org.opencms.publish.CmsPublishEngine.isRunning(
at org.opencms.publish.CmsPublishManager.isRunning(CmsPublishManager.jav
at org.opencms.publish.CmsPublishManager.waitWhileRunning(CmsPublishMana
at org.opencms.publish.CmsPublishManager.waitWhileRunning(CmsPublishMana
at org.opencms.module.CmsModuleImportExportHandler.importData(CmsModuleI
at org.opencms.importexport.CmsImportExportManager.importData(CmsImportE
at org.opencms.setup.CmsSetupBean.importModuleFromDefault(CmsSetupBean.j
at org.opencms.setup.CmsSetupBean.importModulesFromSetupBean(CmsSetupBea
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
at java.lang.reflect.Method.invoke(
at org.opencms.main.CmsShell$CmsCommandObject.executeMethod(CmsShell.jav
at org.opencms.main.CmsShell.executeCommand(
at org.opencms.main.CmsShell.executeCommands(
at org.opencms.main.CmsShell.start(
5 Mar, 2010 3:50:18 PM org.apache.catalina.loader.WebappClassLoader findResource
INFO: Illegal access: this web application instance has been stopped already. C
ould not load org/opencms/main/ The eventual following stack
trace is caused by an error thrown for debugging purposes as well as to attempt
to terminate the thread which caused the illegal access, and has no functional

Should I wait or terminate installation becos as in ur screenshot the total time is approximate 2 hour......
Posted by Dr Ch Subrahmanyam at June 15, 2010 11:14:56 CEST
Usually, OpenCmS installs in a breeze, if everything is configured as per defaults. Having said that, let me restate - the configs:
Tomcat runs on 8080 and is the web &App Server
The Installtion has ROOT in the default location of Tomcat folder
The opencms.war file is uncompressed or expanded by Tomcat (depending upon your configs) to a folder by name - "opencms".

The total time taaken varies from system to system, but should not take couple of hours. On my laptop with 512MB RAM from Lenovo Model 3000 N100 with dual core, it is about 20 minutes in all.

Importing modules does take a long time of these 20 minutes probably about 17to18 minutes.

So, enjoy OpenCMS

Posted by Madhu at June 24, 2010 10:12:37 CEST
Really useful content
Posted by Vinod at September 29, 2010 11:57:12 CEST
I am stuck at step 5 getting error:Servlet Container: Apache Tomcat/ 7.0.2
Your system uses components which have not been tested to work with Alkacon OpenCms. It is possible that OpenCms will not run on your system.
I'm using Apache 7.0.2, opencms6/7, mysql & windows2003.

please help me on this